Car Audio Issue

Discussion in 'General Maintenance' started by Dhillon, Jul 30, 2011.

  1. Dhillon

    Dhillon Administrator Staff Member

    Joined:
    Apr 21, 2011
    Messages:
    1,269
    Likes Received:
    13
    I am experiencing a weird audio issue after installing an amp.Everything works fine when engine if off. When the engine is turn on there is wheezing/screeching sound from rear speakers.

    The setup is like this-
    Front speakers are directly connected to CD system and works fine.
    Rear speakers are connected to amp and amp is connected to CD system via RCA cable.
     
  2. Dhhawal

    Dhhawal New Member

    Joined:
    Apr 26, 2011
    Messages:
    1,292
    Likes Received:
    26
    okay, if the sound is coming from the rear speakers only, you can get a noise filter and route it through your rc, that would be the right thing to do, otherwise an easy fix would be to earth the outside of the rc(from the connector) with the headunit..!
     
  3. Dhillon

    Dhillon Administrator Staff Member

    Joined:
    Apr 21, 2011
    Messages:
    1,269
    Likes Received:
    13
    earthing didn't work, what sort of noise filter should i get ?
     
  4. Dhhawal

    Dhhawal New Member

    Joined:
    Apr 26, 2011
    Messages:
    1,292
    Likes Received:
    26
    its a cheap noise cancelling unit, has two capacitor and chokes to cancel the incoming noise, its referred to as an inline noise filter
    [​IMG]
    take out the rc end from your amp connect it to the input of the filter, take the output of the filter and attach it to the amp and you're good to go...should be cheap, maybe something around 10dollars or so...u'll find it at any car audio shop, one thing i wanna clarify, if the sound coming from the speakers increases with revs of the engine..this fix will work..if it doesn't its probably something else...hit me up if you feel the need
     
  5. Dhhawal

    Dhhawal New Member

    Joined:
    Apr 26, 2011
    Messages:
    1,292
    Likes Received:
    26
    oh and one more thing..these come in all shapes...round, square, whatever..!
     
  6. Dhillon

    Dhillon Administrator Staff Member

    Joined:
    Apr 21, 2011
    Messages:
    1,269
    Likes Received:
    13
    I had to hunt for the 'RCA noise filter' a bit but managed to get one. It has completely solved the issue.costs me Rs 550.
    Thanks Dhhawal ! could never have figured it on my own :)
     
  7. Codename.47

    Codename.47 Guest

    I NEED help as well
    the car that i bought has 4 cd stacker and that one is now locked cuz i put wrong code.should i remove the battery to reset the cd player or just dump that and get a new one?
     
  8. Dhhawal

    Dhhawal New Member

    Joined:
    Apr 26, 2011
    Messages:
    1,292
    Likes Received:
    26
    @Dhillon, always happy to help bud..! :)

    @rahul, i think you should be able to reset it, should have a button at the back of the unit, you can try resetting it from the battery and resetting it but some CD Changers have an EPROM circuit, which means that even tho you disconnect and reconnect, it will still retain its original code..! try it before you decide to dispose it..!
     
  9. Codename.47

    Codename.47 Guest

    im gona keep the battery disconnected because looks like ECU needs resetting too
     
  10. moishenriq

    moishenriq Banned

    Joined:
    Feb 18, 2013
    Messages:
    30
    Likes Received:
    0
    There are many people who are facing some problems in their car and many of them are facing a problem regarding audio so they should check many more things like it is in warranty period or not.
     
  11. Oliversmith

    Oliversmith New Member

    Joined:
    Jan 20, 2014
    Messages:
    16
    Likes Received:
    0
    If you meet with audio issues after amplifier installation, always check whether the wires are blocking the fan in the head unit. Or else check whether there is wire shorting out problems. You should also make sure that the connection is clean and has good contact with ground.
     

Share This Page